Установка разных версий PHP в Plesk 12

Сегодня я буду устанавливать PHP различных версий на сервер с Plesk 12. Для теста выбрана VPS от компании Rusonyx ( в прочем, как всегда) . VPS Root START PLESK , у того, что у меня есть ещё префикс 2014. Нужно отметить, что PLESK в Русониксе отличается от того, что Вы можете развернуть из коробки в лучшую сторону.

Операционная система у нас:
# cat /etc/redhat-release
CentOS release 6.5 (Final)

В PLESK есть возможность выбирать версию PHP но по умолчанию у нас есть только php 5.3.3

Ну, а что если нам нужна другая версия? Например 5.4, или 5.5, или 5.6 Её можно установить дополнительно.

Нам необходимо установить новый репозиторий:

wget -q -O - http://www.atomicorp.com/installers/atomic |sh

Далее, установим панду, php панду.

yum install plesk-php-panda

Устанавливаем со всеми зависимостями, а их много.

После этого у нас будут установлены версии 5.4/5.5/5.6

#  /usr/local/psa/admin/bin/php_handlers_control —list
id:  display name:  version:    type:                                       cgi-bin:  cli-bin:                                   php.ini:
module          5.3.3     5.3.3   module                               /usr/bin/php-cgi                                         /etc/php.ini
fastcgi          5.3.3     5.3.3  fastcgi                               /usr/bin/php-cgi                                         /etc/php.ini
cgi          5.3.3     5.3.3      cgi                               /usr/bin/php-cgi                                         /etc/php.ini
fastcgi-54     Atomic 5.4    5.4.38  fastcgi  /opt/atomic/atomic-php54/root/usr/bin/php-cgi            /opt/atomic/atomic-php54/root/etc/php.ini
fastcgi-55     Atomic 5.5    5.5.22  fastcgi  /opt/atomic/atomic-php55/root/usr/bin/php-cgi            /opt/atomic/atomic-php55/root/etc/php.ini
fastcgi-56     Atomic 5.6     5.6.6  fastcgi  /opt/atomic/atomic-php56/root/usr/bin/php-cgi            /opt/atomic/atomic-php56/root/etc/php.ini

 

 

Об установки более старых версий таких, как 5.2 я напишу в следующих статьях. Наверно )).

Все возможное проблемы и обсуждения ведутся на форуме Parallels Plesk panel http://forum.sp.parallels.com/threads/php-panda-multi-php-installer-for-plesk.293750/page-10

Автор

Светозар

Основатель блога kolesnikov.pw, увлекаюсь свободным ПО и операционной системой Linux(Fedora/Arch). В качестве основной ОС сейчас использую Arhc Linux с Deepin DE.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *